Nuevo plug-in PPAPI de Adobe Flash para Chromium/Chrome en Ubuntu que utiliza (Pepper Flash)

Con las últimas actualizaciones de Chromium habréis notado que no detecta el plug-in de Flash aún teniendo instalada la librería flashpalyer.so y funcionando perfectamente con Firefox, por ejemplo.

La razón es que Google creó hace un tiempo una nueva API llamada PPAPI (Pepper Plug-in API, en contraposición de la standard NPAPI (Netscape Plug-in API) utilizada por los navegadores para la comunicación con los diversos plug-in’s como Flash y, tras marcar NPAPI como “deprecated”, finalmente han decidido dar soporte exclusivamente a PPAPI. Por esta razón, Chromium no detecta el plug-in de Flash, o mejor dicho, simplemente no es compatible.

Todo y que Mozilla dice no “estar interesada en la adopción de PPAPI”, Adobe ha decidido que en las futuras versiones del plug-in de Flash para GNU/Linux solo estarán disponibles vía PPAPI, dando soporte solo a revisiones de seguridad para antiguas versiones del plug-in de Flash basado en NPAPI.

pepper-flash-1

Aunque en mi opinión, esto solo complica las cosas. A partir de ahora tendremos dos librerías, una para Chromium y otra para el resto de navegadores (Chrome es un caso aparte ya que ahora viene con el nuevo plug-in Pepper Flash integrado, por lo que no hay que descargarlo).

flash-pepper-2

Según Google, esta nueva API facilita que los plug-in’s corran en procesos independientes, aparte de otras mejoras, aunque podrían haber creado algún tipo de “wrapper” para hacer cosas así. En fin, que aunque “personalmente no me guste”, tendré que pasar por el aro si quiero seguir utilizando Chromium con Flash y todo y que muchos vaticinaron la muerte de Flash con la llegada de HTML 5 y CSS3, lo cierto es que muchísimos sitios aún necesitan Flash (incluyendo Google).

La solución para poder descargar  el nuevo Pepper Flash para Chromium es tan simple como:

sudo apt-get update
sudo apt-get pepperflashplugin-nonfree

Al instalar el paquete pepperflashplugin-nonfree, lo que hará es descargar directamente el navegador Chrome para poder copiar el plugin de flash basado en PPAPI que ya viene integrado con el navegador Chrome.

Una vez instalado ya podrás utilizar Flash con las nuevas versiones de Chromium.

Si te ha gustado y quieres compartir esta página..