Navegador Opera en Linux Mint 17.1 Rebecca

En mi pequeño arsenal de software imprescindible en las distros de Linux, Opera tiene un papel fundamental, ya que utilizo principalmente Firefox para la navegación general y Opera para abrir sitios relacionados con Gmail, Youtube y otras mierdas de Google que fundamentalmente lo único que hacen es embedir código para rastrearte. No es que vayan a sacar nada importante sobre mi privacidad, es que no me da la gana de vender mi alma y mis datos a nadie. Chrome o Chromium precisamente por ser de Google ya no tienen cabida en mi ordenador.

El otro día estuve instalando la ultima release de Linux Mint, en concreto la 17.1 codename Rebecca y por aquello de la pereza, instale Opera directamente desde los repositorios por defecto con un:

sudo apt-get install opera

Nada mas abrirlo ya me di cuenta que el navegador era tachado de deprecated o obsoleto por algunas webs. Al comprobar que versión me había instalado:

opera_ver

Como podéis ver en la imagen, se trata de la versión 12.16 y en el momento de escribir este post, la última versión para descargar desde la pagina oficial de Opera es la 26.0. Además, al comprobar el plug-in de Flash instalado me dice lo siguiente:

opera_flash_ver

Con lo cual, puedo comprobar que este navegador sigue utilizando la interfaz Netscape Plug-in API y no la nueva Pepper Plug-in API, que es en la cual se desarrollan las últimas versiones de Flash para Linux. Podéis echar un vistazo a una entrada anterior de este Blog donde hablaba acerca de Pepper Plug-in API pinchando aquí.

Por cierto, el plug-in de Flash basado en NPAPI ya viene instalado por defecto en Linux Mint 17.1 Rebecca porqué instalé el sistema basado en la ISO que ya viene con los codecs con copyright integrados. Además, es el plug-in de Flash basado en NPAPI y no PPAPI el que viene instalado por defecto, ya que el navegado integrado es Firefox y éste sigue utilizando la interfaz de plugins NPAPI.

Tras comprobar que no es la versión de Opera mas reciente, paso a desinstalarla con un:

sudo apt-get remove --purge opera

Después, me voy a la pagina oficial de Opera y me descargo el paquete deb 64 bits con la última versión del navegador. En el momento de escribir este post la versión es la 26.0.

Tras descargar el paquete, procedo a su instalación:

sudo dpkg -i opera-stable_26.0.1656.60_amd64.deb

Aunque la instalación falla porqué me dice que no se cumple la dependencia del paquete libcurl3 >= 7.16.2-1, por lo que procedo a refrescar los repositorios y a instalar el paquete libcurl3:

sudo apt-get update
sudo apt-get install libcurl3

Tras instalar el paquete libcurl3, procederá automáticamente a la instalación del anterior paquete de Opera que no se pudo instalar. Nos preguntara si deseamos agregar unas entradas a nuestros repositorios por defecto para que Opera se actualice en el futuro con el resto del sistema de manera automática. Le diremos que sí:

opera_setup_1

 

Tras unos segundos ya tendremos la nueva versión de Opera instalada en nuestro Linux Mint. Procedemos a abrirlo para comprobar la versión:

opera_ver_2

En la imagen podemos ver que la versión efectivamente es la 26.0 y que el motor de renderizado ahora es Webkit en vez del antiguo Presto que se utilizaba en versiones antiguas del mismo. Gracias a este cambio muchas de las webs que visitéis ya no os dirán que el navegador esta obsoleto por culpa del tipo de motor de renderizado.

Como última comprobación, paso a ver que versión del plug-in de Flash detecta este navegador y el resultado es que el plug-in de Flash no está instalado. Esto se debe a que ahora el motor de renderizado es Webkit y por lo tanto, el propio navegador ya no es compatible con la interfaz de plug-ins NPAPI. La buena noticia es que ahora sí es compatible con PPAPI y por lo tanto, podremos hacer funcionar la última versión del plug-in de Flash (16.0), que solo es compatible en Linux con la interfaz PPAPI, tal como hacen otros navegadores basados en Webkit como Chrome o Chromium.

Con esta información, solo nos queda instalar el plug-in de Flash basado en PPAPI con:

sudo apt-get install pepperflashplugin-nonfree

Tras instalar el paquete, cerramos y volvemos a abrir el navegador Opera y al abrir la página de comprobación del plug-in de Flash en http://www.adobe.com/jp/software/flash/about/ , comprobamos que tenemos la misma versión del plug-in de Flash que podríamos tener por ejemplo, en Windows (al momento de escribir este post es la 16.0)

opera_flash_ver_2

 

Por cierto, a mi me sale en japonés porqué es el país donde estoy, pero si substituís en la URL “…/jp/…” por “…/es/…” os saldrá la página en castellano. Es básico, pero lo pongo porque hay mucho tarugo suelto.

Conclusión: No utilicéis siempre los paquetes que vienen incluidos en los repositorios por defecto para instalar nuevo software, ya que muchísimas veces os encontrareis versiones obsoletas.

Si te ha gustado y quieres compartir esta página..